Grupa robocza – komputery na Magei

Home Fora Pomoc Serwery Grupa robocza – komputery na Magei

Ten wątek zawiera 9 odpowiedzi, ma 3 uczestników, ostatnio zmodyfikowany przez piotratorix piotratorix 5 lata, 5 miesięcy temu.

Oglądasz 10 posty - 1 do 10 (z 10 ogółem)
  • Autor
    Posty
  • #1432
    piotratorix
    piotratorix
    Participant

    Witam!
    Jak w temacie. Chcę zrobić sobie grupę roboczą i mieć dostęp do wszystkich komputerów. Mam 3 i na każdym Mageię. Niestety, dostępne artykuły dotyczą jedynie wymiany pomiędzy Linuxem a windą przez sambę.
    Ma ktoś może jakiś artykuł, tylko proszę – nie po angielsku.

    #1433
    napcok
    napcok
    Keymaster

    Myślę, że dla udostępniania zasobów pomiędzy Linuksami dobrą opcją jest NFS.
    Konfiguratory do tego znajdziesz w Centrum Sterowania Magei.
    Centrum Sterowania -> Udostępnianie plików -> Konfiguracja udziałów NFS.
    Konfiguracja jest bardzo prosta.

    Powodzenia 🙂
    Edit: Za pomocą Samby też można, ale jak masz same Linuksy w sieci to chyba lepiej po NFS.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1434
    piotratorix
    piotratorix
    Participant

    Właśnie próbowałem to zrobić za pomocą NFS, ale nie bardzo mi wychodzi. Jutro spróbuję jeszcze raz. Tzn. komputery się zobaczyły, mogłem zamontować wybrane katalogi, ale nie widziałem żadnych plików. Co prawda wybrane mają grubo ponad 10Gb zatem może potrzeba nieco czasu.

    #1435
    mirej
    mirej
    Moderator

    Jeżeli chcesz założyć grupę robocza wspólnie z systemami windowsa, zainstaluj serwer samby.
    Zainstaluj z instalki DVD pakiety: SMB-clients, Samba-common, Samba-server
    Następnie wejdź do Centrum sterowania, udostępnianie plików dalej kliknij w ikonkę udostępnianie plików katalogów systemom windows. Skonfiguruj Nazwę grupy roboczej, Nazwę użytkownika. Ja wpisałem jako “SU” ręcznie do pliku etc/samba/smb.conf
    Powodzenia

    MiReJ,
    Mageia-6 64bit, 4.14
    Mageia-7.1 64bit, 5.2.10

    #1436
    piotratorix
    piotratorix
    Participant

    Mirej – z windą nie ma problemu. Komputer u dzieciaków widzę, ale mam tak ustawione, że tylko w jedną stronę. Tzn. mogę sobie przeglądać go z poziomu linuxa i przesyłać pliki. Z windows nie mogę i o to mi chodziło. Komp dzieciaków robi jako magazyn.
    Potrzebuję spiąć trzy pozostałe na linuxie. Dziś próbowałem, ale nie wychodzi mi.

    #1437
    napcok
    napcok
    Keymaster

    @pitratorix: zwróć uwagę na prawa dostępu do plików i mapowania użytkowników. Jeśli korzystasz z firewalla to musisz odblokować odpowiednie porty.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1438
    piotratorix
    piotratorix
    Participant

    Porty mam odblokowane na NFS – 111 2049
    Teraz nie mam pozostałych, bo są u nas w firmie. Sprawdzę jeszcze jutro, bo dziś dopiero odpaliłem 3ci komp i tak mnie naszło, że dobrze byłoby połączyć je w sieć. Znając życie myślę, że problem będzie banalny.
    Najśmieszniejsze jest to, że pod Sambę wszystko jest opisane – full poradników, a pod NFS nie bardzo.

    #1439
    mirej
    mirej
    Moderator

    Piniższy opis dotyczu Samby.
    Jeżeli pracujesz na Win7 to trzeba dodać konto użytkownika (jako user) nadać mu uprawnienia oraz prawa do udostępniania zasobów. Z Magei-4 wchodzę delfinem, klikam ikonkę Sieć dalej zasoby samby, dalej nazwa_usera_na_windowsie. W okienku wpisuję login i hasło z windowsa i już kożystam z jego zasobów do woli. Istnieje możliwość automatycznego logowania do innego komputera musi być na obydwu ten sam login i hasło. Tego jednak nie sprawdzałem osobiście.

    MiReJ,
    Mageia-6 64bit, 4.14
    Mageia-7.1 64bit, 5.2.10

    #1445
    piotratorix
    piotratorix
    Participant

    Uwaga – temat dla NFS nie jest jeszcze rozwiązany!
    W piątek zachorowałem, grypa, i nie ma mnie w sklepie zatem nie mogę tego dalej pociągnąć. A Samba – jak pisałem na wstępie działa mi bez zarzutu.
    Zdążyłem jeszcze przeinstalować system na stacjonarnych – wróciłem do 3ki. Wydobrzeję pewnie około środy i wtenczas sprawdzę wszystko. Na 4ce, jak pisałem, nic się nie dzieje – nie mogłem ich połączyć, chociaż się widziały i mogłem zamontować napędy.

    #1905
    piotratorix
    piotratorix
    Participant

    Temat sam się rozwiązał. Przeinstalowałem systemy i działa.

    Nie łączę postów. Drugi wpis uważam za potwierdzenie rozwiązania problemu.

Oglądasz 10 posty - 1 do 10 (z 10 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.