Instalacja Adobe Air oraz aplikacji na Magei

Home Fora Pomoc HOWTO, czyli “Jak to zrobić?” Instalacja Adobe Air oraz aplikacji na Magei

Ten wątek zawiera 35 odpowiedzi, ma 9 uczestników, ostatnio zmodyfikowany przez  waldek 1 rok temu.

Oglądasz 15 posty - 16 do 30 (z 36 ogółem)
  • Autor
    Posty
  • #1279

    kyndek
    Participant

    Wpisz tak: ./bin/adl -nodebug ./META-INF/AIR/application.xml .

    #1287

    krzysmxx
    Participant

    Dzięki kyndek – teraz poszło !!!
    BTW instalator proponuje nową wersję, ale nie warto: po zainstalowaniu nowej wersji i uruchomieniu – znowu proponuje nową wersję e-pitów 🙂
    Ale e-pity działają – jeszcze raz dzięki !

    #1288

    kyndek
    Participant

    Cieszę się, że mogłem pomóc 🙂
    BTW – jak zauważyłeś procedura instalacji nowej wersji nie działa, dlatego żeby zaktualizować do najnowszej musisz ponownie pobrać nowszą wersję instalatora .air ze strony e-pity i rozpakować do katalogu z e-pity. Można to robić bez obaw ponieważ pliki z danymi zapisują się w innym katalogu (tzn. tak jest w e-deklaracjach) Tylko w ten sposób można dokonać uaktualnienia. Pozdrawiam.

    #1289

    krzysmxx
    Participant

    Choc gnębi mnie, że nadal nie bardzo rozumiem dlaczego wersja rpm AIR runtime’a nie wystarcza żeby zainstalować program, któremu ona powinna wystarczać ;->

    #1290

    kyndek
    Participant

    O ile się nie mylę AAir używa systemu pakietowania .deb. Na systemach rpm-owych przy instalacji aplikacji korzysta z biblioteki librpm. Niestety, ta biblioteka przez ostatnio czas ulegała dużym modyfikacjom, a ponieważ Adobe dało ciała porzucając wsparcie dla Air i nikt w kodzie Air nie grzebał (bo kod jest zamknięty), dlatego występują błędy przy instalowaniu aplikacji .air. Stąd na systemach debianopochodnych Air runtime działa, bo nie potrzebna jest librpm i konwersja. Jeszcze niedawno na Magei pomagało wrzucenie starej wersji biblioteki librpm, ale skoro używałeś sposobów podanych powyżej i nie działało tzn. że pewnie w jeszcze innej bibliotece, którą używa Air, powstały jakieś modyfikacje, które uniemożliwiają instalację. Dlatego wydaje mi się, że najlepszym sposobem jest skorzystanie z tego rozwiązania i ominięcie procesu instalacji. Tak naprawdę można też napisać skrypt instalacji, który przy uruchamianiu aplikacji sprawdzi jej wersję i zainstaluje, kiedy znajdzie nowszą. Jeśli czas mi pozwoli i będzie takie zapotrzebowanie, to taki skrypt popełnię. Pozdrawiam 🙂

    #1292

    krzysmxx
    Participant

    OK, na razie wsio jasno kyndek -dzięki wielkie 🙂

    #2197
    xpris
    xpris
    Participant

    Witajcie.
    Udało mi się odnaleźć działający sposób instalacji Adobe AIR runtime w Mageia 4. Cała sprawa tak naprawdę rozbija się o akceptację licencji eula pakietu AIR. Dlatego nawet mając zainstalowany pakiet AIR czy to z pliku bin czy rpma program wypluwał przy próbie instalacji wszystkich aplikacji błąd instalatora (nie dając nawet instalacyjnego monitu o hasło roota). Ale jest na to sposób. Co prawda można zrobić tak jak radzono wyżej czyli użyć pakietu SDK, no ale to ma sporo ograniczeń w stosunku do zwykłego AIR runtime.

    Na pomysł z licencją wpadłem przeglądając forum społeczności steam w grze Defenders Quest. Jak się okazuje ich gra w nowej wersji ma już skrypt który pozwala na automatyczne pobranie AIR i jego bezproblemową instalację. Dobra ale przecież dla pakietu AIR nie będziemy przecież kupować gry. Dlatego sięgniemy po wersję demo, która co prawda nie ma wbudowanego tego skryptu ale pozwala na akceptację licencji AIR.

    1. Na wstępie musimy zainstalować wszystkie pakiety rpm (oprócz Adobe AIR), dla danej wersji Mageia jakie podał kyndek w pierwszym poście. Ja mam Mageia 4 x64 na obu komputerach i na obu instalowałem pakiety podane dla MGA 3 X64 – i na obu działa. Nie wiem jak z wersją 32 bitową ale myślę, że też powinno działać.
    2. Teraz pobieramy i instalujemy w systemie oficjalną paczkę RPM z Adobe AIR:

    su 
    urpmi http://airdownload.adobe.com/air/lin/download/2.6/adobeair.i386.rpm

    3. Jeżeli mamy już wszystkie wymagane biblioteki i sam pakiet AIR zainstalowane to teraz trzeba zaakceptować licencję EULA. Chociaż w internecie jest kilka podanych sposobów na to m.in. tutaj na wiki arch linuksa Ale niestety żaden sposób na akceptację licencji w ten sposób u mnie nie działał. Może ktoś znajdzie obejście – to by wiele pomogło.

    Tymczasem jeżeli nie będzie szybszej metody na akceptację licencji, to trzeba pobrać poniższe demo gry i je uruchomić. Uwaga niekiedy w systemie brakuje bibliotek potrzebnych do uruchomienia binariów dema.
    http://www.defendersquest.com/files/defenders_quest_demo_1_0_1_linux/defenders_quest_demo_1_0_1.tar.gz
    U mnie brakowało dwóch bibliotek, ale wszystkie brakujące są w repo systemu. Wystarczy uruchomić binarkę w konsoli (./DefendersQuestDEMO) i zobaczyć co wypluje i brakującą zainstalować. Można też szybciej poleceniem (ldd ./DefendersQuestDEMO) zobaczyć jakich bibliotek brakuje. Kiedy już mamy wszystkie uruchamiany demo i naszym oczom ukaże się nowe okno Adobe AIR z informacją o konieczności akceptacji licencji EULA. Kiedy naciśniemy na przycisk akceptuj, uruchomi nam się automatycznie gra – a to znak, że wszystko z naszym AIR gra. Teraz możemy już bez problemu instalować aplikacje AIR jak edeklaracje, wimp 3 itp.

    Na koniec, piszcie czy ten sposób u was działa, u mnie zadziałał ma dwóch komputerach z Mageia 4 x64. Może ktoś też rozgryzie jak zaakceptować licencję EULA bez konieczności pobierania tego dema…

    🙂

    #2673

    krzysmxx
    Participant

    No tak Panowie, w ubiegłym roku (2014/2015) PITa udało mi się rozliczyć, używając poprzedniej instalacji AIR, ale w tym roku chyba będzie problem, bo nawet AdobeReadera nie mogę zainstalować (używamm okulara, ale do e-pitów chyba nie wystarczy).
    Macie jakiś pomysł na porządny prog. do PIT za 2015 ?
    Mageia 5 64-bit.

    #2674
    xpris
    xpris
    Participant

    No tak Panowie, w ubiegłym roku (2014/2015) PITa udało mi się rozliczyć, używając poprzedniej instalacji AIR, ale w tym roku chyba będzie problem, bo nawet AdobeReadera nie mogę zainstalować (używamm okulara, ale do e-pitów chyba nie wystarczy).
    Macie jakiś pomysł na porządny prog. do PIT za 2015 ?
    Mageia 5 64-bit.

    Czemu? Sposób powyżej na instalację AIR działa na Mageia 4, powinien działać też na Mageia 5 – powinien, bo nie testowałem.
    Adobe Reader również powinien działa bez przeszkód.
    Inna sprawa rok temu to o ile dobrze pamiętam rozliczałem PIT w eDeklaracje z Linux Mageia i to bez Adobe Reader… więc nawet bez programu powinno być ok.

    #2675

    krzysmxx
    Participant

    Kwestia jest tego typu że Adobe AIR mam zainstalowane, z czasów gdy miałem Mageię 2 32-bit: tzn. aplikacja e-pity2015.air instaluje się bez żadnych komunikatów o błędach, ale uruchomić sie nie chce, więc myślałem że można “na skróty” 🙂

    #2678

    daro2
    Participant

    Faktycznie, od pewnego czasu uruchomienie aplikacji z rozszerzeniem.air generuje poważne problemy w środowisku Linux-a, wręcz nie do przejścia.Dlatego proponuje zainstalowanie Adobe AIR za pomocą wine.

    Instalacja wine za pomocą polecenia:
    urpmi wine

    Instalacja AdobeAIRInstaller.exe za pomocą menu kontekstowego (Otwórz za pomocą Wine Windows Program Loader). Podczas instalacji należy poczekać aż wine zainstaluje wszystkie zależności potrzebne do prawidłowego działania Adobe AIR.exe i dopiero akceptować warunki licencji AdobeAIRInstaller.exe.

    Instalacja setup_e-pity2015Linux.air za pomocą menu kontekstowego (Otwórz za pomocą Adobe AIR Aplikation Instaler ) pobrałem wersie dla linux-a, nie przeszkodziło to jednak w instalacji aplikacji na wine.

    Po instalacji: Programy-> Inne-> e-Pity 2015

    Strona domowa: e – Pity 2015

    Strona domowa: Adobe AIR

    Załączniki:
    #2680

    krzysmxx
    Participant

    Dzięki daro2, rzeczywiście to działa.
    Z jednym wyjątkiem – tu-ówdzie zamiast fontów w programie e-pity są przekreślone kwadraciki.
    Nie wiesz jakich fontów może mi brakować (ew. jakie w tym miejscu są) ? BTW też użyłem e-pity2015.air na linuksa.

    Załączniki:
    #2682

    krzysmxx
    Participant

    I jeszcze jedna sprawa: zapytałem pomoc techniczną e-pitów na info.e-deklaracje@mf.gov.pl:

    “czy wersja online będzie działać jeśli zamiast Adobe Readera będę mieć inną wtyczkę do przeglądarki WWW, czytającą PDF ?”

    odpowiedź raczej smutna:

    Niestety musi to być Adobe Reader
    ponieważ tylko on obsługuje formularze. Większość wtyczek ogranicza się tylko do obsługi podstawowej pdf.

    Pozdrawiamy,

    Zespół Pomocy Technicznej Portalu Podatkowego i e-Deklaracji
    Centrum Kompetencyjne Portalu Podatkowego
    w Izbie Skarbowej w Łodzi
    tel.: +48 801 055 055
    lub +48 22 330 03 30

    e-mail: info.e-deklaracje@mf.gov.pl

    czyli w praktyce na większości 64-bit dystrybucji linuksa natywnej e-deklaracji wysłać się nie da, nawet online !!!

    EDIT: ale z drugiej strony uruchomiłem e-pity 2015 online i wydaje się że wszystko normalnie działa: na końcu formularz wypełniony był OK (wpisałem trochę danych “na pałę”).
    No i ciekawe czy taki kombajn jak Master PDF Editor też nie da rady ?

    #2683

    krzysmxx
    Participant

    Mam nadzieję że to, przynajmniej chwilowo, koniec tematu z mojej strony: poniżej odpowiedź z f-my e-pity

    Witam, Adobe Reader nie jest w ogóle wymagany – bo to tylko do wydruku ściąga plik i otwiera się w domyślnym programie do PDFów, jakby coś Panu nie zadziałało to z góry dziękuję za informację

    Pozdrav,
    Krzysiek

    #2685

    daro2
    Participant

    Dzięki daro2, rzeczywiście to działa.
    Z jednym wyjątkiem – tu-ówdzie zamiast fontów w programie e-pity są przekreślone kwadraciki.
    Nie wiesz jakich fontów może mi brakować (ew. jakie w tym miejscu są) ? BTW też użyłem e-pity2015.air na linuksa.

    Od momentu instalacji systemu, nie zmieniałem czcionek w systemie.

    Załączniki:
Oglądasz 15 posty - 16 do 30 (z 36 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.