Mageia 3 – Kadu, Skype i Amarok nie działa.

Home Fora Pomoc Oprogramowanie Mageia 3 – Kadu, Skype i Amarok nie działa.

Ten wątek zawiera 28 odpowiedzi, ma 8 uczestników, ostatnio zmodyfikowany przez m123456 m123456 3 lata, 10 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 29 ogółem)
  • Autor
    Posty
  • #784
    mirej
    mirej
    Participant

    Po świeżej instalacji Mageia 3 nie uruchamiają się programy Kadu, Skype, Amarok, AcetoneISO dociągnięte z repozytoriów.
    [root@localhost ala]# kadu
    Błędna instrukcja

    [root@localhost ala]# skype
    /usr/bin/skype: line 2: 3197 Przerwane LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so /usr/share/skype/skype

    [root@localhost ala]# amarok
    unnamed app(3246): KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
    unnamed app(3244): KUniqueApplication: Pipe closed unexpectedly.

    Platforma sprzętowa to Athlon XP2000+ i ATI Radeon.

    MiReJ,
    Mageia-6 64bit, kernel 4.9.50
    Mageia-5 32bit

    #785
    napcok
    napcok
    Keymaster

    Świeża instalacja, ale za pomocą czego ? LiveDVD, DVD, dualCD?
    Dlaczego z roota?

    Mabox Linux | Linux is like a wigwam, no windows, no gates an Apache inside

    #787

    waldek
    Participant

    U mnie jest podobnie tylko nie wiem co z kadu bo nie ma zainstalowanego ale Skype i Amarok nie uruchamiają się. Instalacja z DVD Mageia 3 32 bit KDE.
    [waldek@localhost ~]$ skype
    /usr/bin/skype: line 2: 10930 Przerwane LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so /usr/share/skype/skype

    [waldek@localhost ~]$ amarok
    libv4l2: error getting pixformat: Zły argument
    KCrash: Application 'amarok' crashing...
    KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
    sock_file=/home/janek/.kde4/socket-localhost/kdeinit4__0
    unnamed app(11035): Communication problem with "amarok" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

    #788
    napcok
    napcok
    Keymaster

    Na bugzilli jest błąd dotyczący 32bit wersji KDE -> https://bugs.mageia.org/show_bug.cgi?id=10157
    Może to coś podobnego?

    Mabox Linux | Linux is like a wigwam, no windows, no gates an Apache inside

    #790

    waldek
    Participant

    Zainstalowanie ftp://rpmfind.net/linux/mageia/distrib/3/i586/media/core/updates_testing/libqtwebkit2.2_4-2.3.0-1.1.mga3.i586.rpm
    pomogło amarok uruchamia się tylko przy próbie odtwarzania mp3 wyszukuje wtyczek Dekoder MPEG-1 Layer 3.
    Jaki trzeba doinstalować pakiet?
    Natomiast w sprawie skype nic się nie zmieniło.
    Dzięki Napcok

    #794
    mirej
    mirej
    Participant

    Dzięki kol napcok i waldek wszystkie programy ruszyły.
    Pozostał problem ze Skype 4.2 uruchamia się do ikonki na try i znika!

    Platforma sprzętowa to Athlon XP2000+ i ATI Radeon.
    (Na CPU Intela problemów nie było).

    MiReJ,
    Mageia-6 64bit, kernel 4.9.50
    Mageia-5 32bit

    #797
    aquila.pl
    aquila.pl
    Moderator

    @waldek zobacz czy masz lame
    rpm -qa | grep lame
    @mirej co wypluwa konsola przy uruchomieniu skype?

    #798

    waldek
    Participant

    [waldek@localhost ~]$ rpm -qa | grep lame
    gstreamer1.0-twolame-1.0.5-2.mga3
    libtwolame0-0.3.13-3.mga3
    twolame-0.3.13-3.mga3

    jeśli chodzi o skype
    [waldekk@localhost ~]$ skype
    /usr/bin/skype: line 2: 4258 Przerwane LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so /usr/share/skype/skype

    #799
    m123456
    m123456
    Moderator

    Pokaż:
    ldd /usr/lib/libv4l/v4l2convert.so
    ldd /usr/share/skype/skype

    Uruchom skype poleceniem:
    /usr/share/skype/skype
    oraz sprawdź:
    strace /usr/share/skype/skype

    #800

    waldek
    Participant

    [waldek@localhost ~]$ ldd /usr/lib/libv4l/v4l2convert.so
    linux-gate.so.1 (0xffffe000)
    libv4l2.so.0 => /lib/libv4l2.so.0 (0xb7706000)
    libc.so.6 => /lib/i686/libc.so.6 (0xb7553000)
    libv4lconvert.so.0 => /lib/libv4lconvert.so.0 (0xb74db000)
    libpthread.so.0 => /lib/i686/libpthread.so.0 (0xb74c1000)
    /lib/ld-linux.so.2 (0xb772e000)
    librt.so.1 => /lib/i686/librt.so.1 (0xb74b7000)
    libm.so.6 => /lib/i686/libm.so.6 (0xb7474000)
    libjpeg.so.8 => /lib/libjpeg.so.8 (0xb741d000)

    [waldek@localhost ~]$ ldd /usr/share/skype/skype
    linux-gate.so.1 (0xffffe000)
    libasound.so.2 => /lib/libasound.so.2 (0xb591e000)
    libXv.so.1 => /lib/libXv.so.1 (0xb5918000)
    libXss.so.1 => /lib/libXss.so.1 (0xb5914000)
    librt.so.1 => /lib/i686/librt.so.1 (0xb590b000)
    libdl.so.2 => /lib/libdl.so.2 (0xb5906000)
    libX11.so.6 => /lib/libX11.so.6 (0xb57cd000)
    libXext.so.6 => /lib/libXext.so.6 (0xb57bb000)
    libQtDBus.so.4 => /lib/libQtDBus.so.4 (0xb573c000)
    libQtWebKit.so.4 => /lib/libQtWebKit.so.4 (0xb3726000)
    libQtXml.so.4 => /lib/libQtXml.so.4 (0xb36e6000)
    libQtGui.so.4 => /lib/libQtGui.so.4 (0xb2c19000)
    libQtNetwork.so.4 => /lib/libQtNetwork.so.4 (0xb2add000)
    libQtCore.so.4 => /lib/libQtCore.so.4 (0xb27f4000)
    libpthread.so.0 => /lib/i686/libpthread.so.0 (0xb27da000)
    libstdc++.so.6 => /lib/libstdc++.so.6 (0xb26f2000)
    libm.so.6 => /lib/i686/libm.so.6 (0xb26af000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb2691000)
    libc.so.6 => /lib/i686/libc.so.6 (0xb24dd000)
    /lib/ld-linux.so.2 (0xb5a2b000)
    libxcb.so.1 => /lib/libxcb.so.1 (0xb24bb000)
    libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xb2470000)
    libz.so.1 => /usr/lib/libz.so.1 (0xb2457000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb244c000)
    libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb23f4000)
    libpng15.so.15 => /usr/lib/libpng15.so.15 (0xb23a7000)
    libQtLocation.so.1 => /usr/lib/libQtLocation.so.1 (0xb2253000)
    libQtSensors.so.1 => /usr/lib/libQtSensors.so.1 (0xb222a000)
    libudev.so.1 => /usr/lib/libudev.so.1 (0xb2219000)
    libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb20bb000)
    libgstapp-0.10.so.0 => /usr/lib/libgstapp-0.10.so.0 (0xb20ae000)
    libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xb209d000)
    libgstpbutils-0.10.so.0 => /usr/lib/libgstpbutils-0.10.so.0 (0xb207a000)
    libgstvideo-0.10.so.0 => /usr/lib/libgstvideo-0.10.so.0 (0xb205c000)
    libgstbase-0.10.so.0 => /usr/lib/libgstbase-0.10.so.0 (0xb1ffa000)
    libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xb1f12000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb1ec3000)
    libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb1ebe000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb1ebb000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb1d64000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb1c68000)
    libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb1bb6000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb1b7d000)
    libQtXmlPatterns.so.4 => /usr/lib/libQtXmlPatterns.so.4 (0xb177b000)
    libQtOpenGL.so.4 => /usr/lib/libQtOpenGL.so.4 (0xb167c000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0xb161b000)
    libfreetype.so.6 => /lib/libfreetype.so.6 (0xb1590000)
    libSM.so.6 => /lib/libSM.so.6 (0xb1587000)
    libICE.so.6 => /lib/libICE.so.6 (0xb156d000)
    libXi.so.6 => /lib/libXi.so.6 (0xb155d000)
    libXrandr.so.2 => /lib/libXrandr.so.2 (0xb1551000)
    libXfixes.so.3 => /lib/libXfixes.so.3 (0xb154b000)
    libXcursor.so.1 => /lib/libXcursor.so.1 (0xb1540000)
    libXinerama.so.1 => /lib/libXinerama.so.1 (0xb153c000)
    libssl.so.1.0.0 => /lib/libssl.so.1.0.0 (0xb14d1000)
    libcrypto.so.1.0.0 => /lib/libcrypto.so.1.0.0 (0xb12f9000)
    libXau.so.6 => /lib/libXau.so.6 (0xb12f5000)
    libXdmcp.so.6 => /lib/libXdmcp.so.6 (0xb12ee000)
    libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0xb12af000)
    libresolv.so.2 => /usr/lib/libresolv.so.2 (0xb1295000)
    liborc-0.4.so.0 => /usr/lib/liborc-0.4.so.0 (0xb1206000)
    libffi.so.6 => /usr/lib/libffi.so.6 (0xb11ff000)
    liblzma.so.5 => /usr/lib/liblzma.so.5 (0xb11ca000)
    libpcre.so.1 => /usr/lib/libpcre.so.1 (0xb1162000)
    libglapi.so.0 => /usr/lib/libglapi.so.0 (0xb1142000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb113e000)
    libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xb113b000)
    libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0xb1122000)
    libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0xb111c000)
    libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb1115000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb1108000)
    libuuid.so.1 => /lib/libuuid.so.1 (0xb1103000)
    libgssapi_krb5.so.2 => /lib/libgssapi_krb5.so.2 (0xb10bb000)
    libkrb5.so.3 => /lib/libkrb5.so.3 (0xb0ff1000)
    libcom_err.so.2 => /lib/libcom_err.so.2 (0xb0feb000)
    libk5crypto.so.3 => /lib/libk5crypto.so.3 (0xb0fb5000)
    libkrb5support.so.0 => /lib/libkrb5support.so.0 (0xb0fa8000)

    [waldek@localhost ~]$ /usr/share/skype/skype
    Przerwane

    Po poleceniu strace /usr/share/skype/skype zachowanie jest identyczne jak przy poleceniu wcześniejszym na chwile pojawia się okienko i znika, kończy się napism w konsoli Przerwane.

    #807
    m123456
    m123456
    Moderator
    #808

    waldek
    Participant

    Dzięki @m1123456 wersja skype-4.0.0.8-1mga2 działa, natomiast co jest z amarokem przy próbie odtwarzania mp3 wyszukuje wtyczek Dekoder MPEG-1 Layer 3.

    #809
    mirej
    mirej
    Participant

    Sprawdz ldd /bin/amarok
    czy masz
    libmp3lame.so.0 => /lib/libmp3lame.so.0 (0xafb0f000)
    libFLAC.so.8 => /lib/libFLAC.so.8 (0xae863000)

    Dodaj pakiet RPM liblame0 najlepiej tajnted

    MiReJ,
    Mageia-6 64bit, kernel 4.9.50
    Mageia-5 32bit

    #811

    waldek
    Participant

    Mimo zainstalowania liblame0 oraz lame-3.99.5-3.mga3.tainted.i586.rpm nie widzę
    libmp3lame.so.0 => /lib/libmp3lame.so.0 (0xafb0f000)
    Po sprawdzeniu w katalogu jest dowiązanie w skazuje na libmp3lame.so.0.0
    , natomiast
    libFLAC.so.8 => /lib/libFLAC.so.8 (0xae863000) jest.
    Nadal jest tak samo przy próbie odtworzenia mp3

    #812
    Norbi
    Norbi
    Participant

    Amarok ma to do siebie że czasem nie chce odtwarzać plików jeśli nie są zainstalowane pakiety:
    faad2
    xine-faad

    Linux is funny 🙂

Oglądasz 15 posty - 1 do 15 (z 29 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.