[SOLVED] Nie mogę zainstalowć DraftSight

Home Fora Pomoc Oprogramowanie [SOLVED] Nie mogę zainstalowć DraftSight

Ten wątek zawiera 19 odpowiedzi, ma 3 uczestników, ostatnio zmodyfikowany przez  waldek 2 lata, 1 miesiąc temu.

Oglądasz 15 posty - 1 do 15 (z 20 ogółem)
  • Autor
    Posty
  • #2741

    waldek
    Participant

    Witam,
    Jak w tytule, pojawia się komunikat:
    “niektóre z wybranych pakietów nie mogą być zainstalowane ….. z powodu nie satysfakcjonującego pakietu libGLU.so.1.
    Jeśli próbuję zainstalować ten pakiet to on woła o kolejny podobnym monitem, następny o inny i tak dalej.
    Mageia 5 64 bit.
    Co jest nie tak? Proszę o pomoc.
    Waldek

    #2742
    napcok
    napcok
    Keymaster

    Wygląda na to, że masz coś popsute z konfiguracją repozytoriów…
    Plik libGLU.so.1 znajduje się w paczce libmesaglu1.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #2743

    waldek
    Participant

    System zainstalowany od nowa.
    Przy próbie instalacji paczki libmesaglu1 pojawia się komunikat brak pakietu o tej nazwie.

    #2744
    napcok
    napcok
    Keymaster

    Dla 64bit to będzie paczka lib64mesaglu1 (jest w repozytorium core – podstawowym).
    Skonfiguruj repozytoria:
    tu -> https://mageia.org.pl/konfiguracja-nosnikow-aktualizacja-systemu-i-instalacja-programow/
    lub tu -> http://starter.mageia.org.pl/#/repozytoria/konsola

    Jeśli korzystasz z MCC to przy wuszukiwaniu paczek zaznacz żeby pokazywał “wszystko” a nie tylko “programy z interfejsem graficznym”

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #2745

    waldek
    Participant

    Komunikat:
    Pakiet lib64mesaglu1-9.0.0-5.mga5.x86_64 jest już zainstalowany w systemie.

    #2746
    napcok
    napcok
    Keymaster

    Więc jest też plik o którym piszesz w pierwszym poście – libGLU.so.1.
    W takim razie nie wiem w czym problem, nie mam szklanej kuli.
    Być może jakbyś wklejał dokładne komunikaty błędów to miałoby to jakiś sens i pozwoliłoby ogarnąć co tak naprawdę się dzieje.

    Jeśli możesz to uruchom instalację tego DraftSight z konsoli za pomocą polecenia urpmi i wklej błąd.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #2747

    waldek
    Participant

    [root@localhost Pobrane]# urpmi draftSight.rpm
    Wybrany pakiet nie może zostać zainstalowany:
    draftsight-2015.3.0.3020-1.x86_64 (z powodu niesatysfakcjonującego pakietu libGLU.so.1)
    Czy kontynuować mimo to? (T/n)T
    Podczas gdy niektóre pakiety mogły zostać zainstalowane, nastąpiły błędy.
    Wybrany pakiet nie może zostać zainstalowany:
    draftsight-2015.3.0.3020-1.x86_64 (z powodu niesatysfakcjonującego pakietu libGLU.so.1)
    Czy kontynuować mimo to?
    [root@localhost Pobrane]#

    #2748
    napcok
    napcok
    Keymaster

    Nie wiem skąd masz ten pakiet w starszej wersji, ale wersja aktualna ( draftsight-2016.1.0.2021-1 – paczka dla Fedory ) do pobrania z http://www.3ds.com/products-services/draftsight-cad-software/free-download/

    instaluje się bezproblemowo

    Załączniki:

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #2750

    waldek
    Participant

    U mnie nie.
    [root@localhost Pobrane]# urpmi draftSight.rpm
    Wybrany pakiet nie może zostać zainstalowany:
    draftsight-2016.1.0.2021-1.x86_64 (z powodu niesatysfakcjonującego pakietu libGLU.so.1)
    Czy kontynuować mimo to? (T/n) T
    Podczas gdy niektóre pakiety mogły zostać zainstalowane, nastąpiły błędy.
    Wybrany pakiet nie może zostać zainstalowany:
    draftsight-2016.1.0.2021-1.x86_64 (z powodu niesatysfakcjonującego pakietu libGLU.so.1)
    Czy kontynuować mimo to?
    Nadal jest to samo.

    #2752
    napcok
    napcok
    Keymaster

    Jak możesz to wklej wynik polecenia:
    rpm -ql lib64mesaglu1 | grep libGLU.so.1

    Być może musisz też zainstalować 32bitowe libmesaglu1 (u mnie jest zainstalowane)

    Jeśli to nie pomoże to problemem jest to że masz:

    1. Źle skonfigurowane repozytoria
    albo
    2. Mirror z którego urpmi pobiera pakiety jest niekompletny
    albo
    3. Nie zaktualizowany system

    Linki masz podane w 4-tym poście w wątku.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #2753

    waldek
    Participant
    [root@localhost Pobrane]# rpm -ql lib64mesaglu1 | grep libGLU.so.1
    /usr/lib64/libGLU.so.1
    /usr/lib64/libGLU.so.1.3.1
    #2754
    aquila.pl
    aquila.pl
    Moderator

    Zrób tak.
    1. Włącz wszystkie 32 bit repozytoria Release i Updates.
    2. W konsoli:

    urpmi --auto-update
    3. Potem:

    urpmi libmesaglu1
    4. Możliwe, że trzeba będzie doinstalować:
    urpmi libaudio.so.2
    i spróbuj zainstalować program.

    #2755

    waldek
    Participant

    Dzięki napcok i Tobie aquila.pl doinstalowanie 32bitowe libmesaglu1 rozwiązało problem.

    #2802

    waldek
    Participant

    Witam,
    Pojawiła się nowa wersja draftSight-2016.2.0.3034-1.x86_64.rpm, postanowiłem zainstalować jednak przy próbie uruchomienia w konsoli pojawia się komunikat ./DraftSight: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory.
    Pakiet z tym plikiem zainstalowałem ale to nic nie dało.
    Proszę o pomoc.

    #2804
    aquila.pl
    aquila.pl
    Moderator

    Pokaż;
    find /usr -name libpng12.so.0
    Jaką paczkę instalowałeś z libpng12.so.0?

Oglądasz 15 posty - 1 do 15 (z 20 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.