[SOLVED]Problem z WiFi – BCM43142.

Home Fora Pomoc Sprzęt i sterowniki [SOLVED]Problem z WiFi – BCM43142.

Ten wątek zawiera 20 odpowiedzi, ma 3 uczestników, ostatnio zmodyfikowany przez  Adam Kowalski 4 lata, 2 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 21 ogółem)
  • Autor
    Posty
  • #1614

    Adam Kowalski
    Participant

    Dzisiaj postanowiłem rozszerzyć swoje horyzonty i równocześnie z Win7 zainstalowałem Mageię 4 i mam problem. Nie mogę połączyć się z żadną siecią WiFi, w ogóle nie wykrywa sieci bezprzewodowych, zakładam, że nie został poprawnie zainstalowany sterownik (pod Win7 też ręcznie musiałem go instalować).

    Mam laptop Lenovo B590 z kartą sieci bezprzewodowych LAN PCI Express 1×1 11b/g/n Half Mini.
    Co mam zrobić?

    (Proszę o informację, najlepiej krok po kroku bo w Linuxie jestem zielony) Z góry dziękuję.

    #1615
    napcok
    napcok
    Keymaster

    Witaj,
    Możesz spróbować doinstalować pakiety: kernel-firmware-nonfree oraz rtlwifi-firmware.
    Być może to pomoże.

    Jeśli nie, to przydałyby się dokładne informacje o modelu karty
    Pokaż co pokazuje polecenie lspci.
    (Jeśli masz KDE to prawoklik na pulpicie -> Konsola -> wpisz lspci[ENTER] i wklej tutaj co pokazuje konsola)

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1617

    Adam Kowalski
    Participant

    Zrzut…

    Załączniki:
    #1619

    Adam Kowalski
    Participant

    Pakiety które wymieniłeś nie mogę zainstalować. Wyskakuje mi komunikat, że są w konflikcie z już zainstalowanymi.

    #1620
    napcok
    napcok
    Keymaster

    Chodzi o kartę: broadcom corporation bcm43142 802.11b/g/n (rev 01)

    Kojarzę że ktoś z forumowiczów walczył już z tą kartą. Jak przeczyta to pewnie pomoże 🙂

    @Adam Kowalski: jak są jakieś błędy (Komunikaty) to najlepiej je wkleić na forum jako tekst

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1621

    Adam Kowalski
    Participant
    #1624
    napcok
    napcok
    Keymaster

    Widzę, że kolega robi jakieś bardzo dziwne rzeczy próbując instalować paczki …
    Myślę że warto przeczytać artykuł…

    Konfiguracja nośników, aktualizacja systemu i instalacja programów

    W magei rpmy instaluje się za pomocą Rpmdrake lub w konsoli za pomocą urpmi, np:

    su -
    urpmi kernel-firmware-nonfree

    gdzie po komendzie su – jesteśmy proszeni o wpisanie hasła roota, które należy wpisać (nie pojawia się na ekranie) i klepnąć ENTER 🙂

    Pozdrawiam

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1625

    Adam Kowalski
    Participant

    OK, mój błąd 🙂
    Jednak nadal jest problem….
    Przy instalacji pakietu rtlwifi-firmware otrzymuję komunikat, że pakiet jest już zainstalowany.

    #1628
    aquila.pl
    aquila.pl
    Moderator

    Witam
    Pokaż wynik z konsoli:

    urpmq --list-url
    uname -a
    rpm -qa | grep broadcom

    Admin @napcok prosił o wklejanie tekstu a nie zrzutów. Kopiujesz z konsoli co wypluwa, przy edycji posta wciskasz code, wklejasz teks i zamykasz /code. Jest to bardziej czytelne dla nas.

    #1629

    Adam Kowalski
    Participant

    Wpisałem komendy i otrzymałem:

    [adamkowalski@localhost ~]$ su 
    Hasło:  
    [root@localhost adamkowalski]# urpurpmq --list-url 
    bash: urpurpmq: nie znaleziono polecenia 
    [root@localhost adamkowalski]# uname -a 
    Linux localhost 3.12.8-desktop-2.mga4 #1 SMP Fri Jan 24 13:56:55 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux 
    [root@localhost adamkowalski]# rpm -qa | grep broadcom 
    broadcom-bcma-config-1-4.mga4 
    [root@localhost adamkowalski]# 
    #1630
    aquila.pl
    aquila.pl
    Moderator

    Wkradł mi się błąd. Poprawiłem pierwszą komendę. Spróbuj doinstalować:
    dkms-broadcom-wl

    #1633

    Adam Kowalski
    Participant

    urpmq –list-url

    [root@localhost adamkowalski]# urpmq --list-url
    Core Release cdrom://x86_64/media/core
    Nonfree Release cdrom://x86_64/media/nonfree
    [root@localhost adamkowalski]# 

    dkms-broadcom-wl

    [root@localhost adamkowalski]# urpmi dkms-broadcom-wl.rpm 
    W celu spełnienia zależności 'devel(libstdc++(64bit))' niezbędny jest jeden z poniższych pakietów:  
    1- libstdc++-devel-4.8.2-3.mga4.x86_64: Header files and libraries for C++ development (do zainstalowania)
    2- libstdc++5-devel-3.3.6-9.mga4.x86_64: Header files and libraries for C++ development (do zainstalowania)
    Jaki jest Twój wybór? (1-2)

    Który z pakietów mam zainstalować?
    Czy do instalacji pakietów potrzebuje aktywnego łącza z Internetem?

    #1634
    napcok
    napcok
    Keymaster

    Który z pakietów mam zainstalować?

    Nie ma to znaczenia, wybierz którykolwiek.

    Czy do instalacji pakietów potrzebuje aktywnego łącza z Internetem?

    W tej chwili masz skonfigurowane nośniki (repozytoria) tylko z płyty cd, więc na razie nie.

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

    #1635

    Adam Kowalski
    Participant

    System instalowałem z Pendriva a nie z CD/DVD to ma jakieś znaczenie?

    #1636
    napcok
    napcok
    Keymaster

    Jakbyś miał cd/dvd to mógłbyś z niego doinstalować pakiety. Nie mam pojęcia czy z Pendrive się da (w łatwy sposób).

    Czy masz możliwość podpięcia się przez kabel do netu?

    Manjaro.PL | Linux is like a wigwam, no windows, no gates an Apache inside

Oglądasz 15 posty - 1 do 15 (z 21 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.